32 lines
561 B
Nix
32 lines
561 B
Nix
{
|
|
description = "linapple";
|
|
|
|
inputs = {
|
|
nixpkgs = {
|
|
url = "github:nixos/nixpkgs/nixos-unstable";
|
|
};
|
|
flake-utils = {
|
|
url = "github:numtide/flake-utils";
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
flake-utils,
|
|
...
|
|
}:
|
|
flake-utils.lib.eachDefaultSystem
|
|
(
|
|
system: let
|
|
pkgs = import nixpkgs {
|
|
inherit system;
|
|
};
|
|
in {
|
|
packages = {
|
|
linapple = pkgs.callPackage ./package.nix {};
|
|
default = self.packages.${system}.linapple;
|
|
};
|
|
}
|
|
);
|
|
}
|